Trouble adding folders to Copy Files list

Advanced Renamer forum
#1 : 11/10-14 22:07
bland328
bland328
Posts: 4
I'm having a lot of trouble adding folders full of files and subfolders to the Copy Files list.

Here's an example of the problem:

I have a folder named "Cameras", containing only a folder named "DCIM", which contains 199 JPG image files.

If I add the "Cameras" folder to an empty Copy Files list (with Include Subfolders turned on and a Filename Mask of *.*), I get ZERO files in the list.

If I add the "DCIM" subfolder to the empty Copy Files list in the same manner, I get all 199 files in the list.

I have a lot of deep folder structures giving me this trouble, so I do need to figure out how to overcome it. This was simply the simplest case I could come up with to demonstrate the problem.

Thanks,
B


11/10-14 22:07
#2 : 11/10-14 22:36
Stefan
Stefan
Posts: 262
Reply to #1:
 
EDIT / Solved:
See last post of bland328:
"""Mysteriously, some of the folders had the System bit (+S attribute) set, and AR ignored all such folders."""



---------------------------------------------------


Hmm, that should simple work?


Add > Directories... >>> top main folder
[x] Include Subdirectories
Mask *.*
[OK]

(Note: trailing or leading spaces on mask will break it and end in adding no files)



Works for me with 3.64 on Win7 (32 bit)





 

----------
If this tool had saved you time, perhaps you want to donate an Dollar to Kim?
See http://www.advancedrenamer.com/download >>> [Donate] button.


11/10-14 22:36 - edited 14/10-14 07:28
#3 : 11/10-14 23:46
bland328
bland328
Posts: 4
Reply to #2:

I agree that it should be that simple! Something very strange is going on, and I have many folders demonstrating this behavior.

I'm configured just as you describe, and have no trailing space on the Mask.

I'm using Advanced Renamer 3.64 under Windows 8.1 x64, and have seen this behavior both when accessing folders from an SMB share, and on my NTFS boot partition.

Using Sysinternals Process Monitor to watch the file system activity of ARen.exe, I see that it calls QueryDirectory on the Cameras directory, that the DCIM subfolder is successfully reported, but that Advanced Renamer never queries the DCIM subfolder.

I'm stumped. Any thoughts?

EDIT: Also, to be clear, I can find some folders on which Advanced Renamer DOES properly dig down through all the subfolders, and can also find many on which it doesn't. I simply can't, however, figure out how a successful folder structure and an unsuccessful structure differ, especially since my sample is so simple.


11/10-14 23:46 - edited 11/10-14 23:49
#4 : 11/10-14 23:57
bland328
bland328
Posts: 4
Reply to #3:

Here's an update:

AR doesn't like a lot of folders out on my file server, through an SMB connection.

And even when those problem folders are copied locally to an NTFS drive, AR *still* doesn't like them.

If I locally, on the NTFS drive, make the same folder structure as my test case by hand, then copy the JPGs into the DCIM folder, AR likes that just fine.

So my hypothesis is that AR is choking on some subtle property of these folders that survives the move from SMB network share to local NTFS folders, though I can't fathom what that would be.

Perhaps copying them to a local FAT32 drive would fix the situation, since FAT32 doesn't support much in the way of per-folder or per-file metadata, but that's not a practical solution, given the size and number of files I'm trying to process.

So...still open to suggestions, because AR *otherwise* seems like the perfect tool for my task.


11/10-14 23:57
#5 : 13/10-14 19:52
bland328
bland328
Posts: 4
Reply to #4:
Problem solved!

Mysteriously, some of the folders had the System bit (+S attribute) set, and AR ignored all such folders.

After using the attrib command to recursively turn off the System bit on everything in my collection, AR is working fine.

I hope this saves someone else some pain one of these days!


13/10-14 19:52