Exception EReadError

Advanced Renamer forum
#1 : 03/02-15 13:45
Fajar Rosyadi
Fajar Rosyadi
Posts: 3
I got error in Win 8.1 x64, it show

"Exception EReadError in module ARen.exe at 00057F74. Error reading treeAddFolderTree.lndent: Access violation at address 00408B3B in module 'ARen.exe'. Read of address 00000008"

any idea for this problem?

thanks


03/02-15 13:45
#2 : 12/02-15 09:10
A
A
Posts: 4
Reply to #1:
hi, I have the same error. On the other pc the software works well, on my pc it suddenly stopped working (and i usually used it a lot). What can i do to fix it?

Thank you in advance!


12/02-15 09:10
#3 : 12/02-15 20:47
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #1:
That is odd. Are you still able to start the program?

I will recommend removing your settings so the program will start up fresh. Your data is located here: c:\Users\YOUR USERNAME\appdata\Roaming\Hulubulu\Advanced Renamer 3

You can also try to download the portable version of Advanced Renamer and unzip and run it from a new location.


12/02-15 20:47
#4 : 13/02-15 00:19
A
A
Posts: 4
Reply to #3:

Until three months ago it worked well, but now it doesn't open at all.
I tried this evening the portable version but it still doesn't work. Also old versions don't work.

This is the screenshot of the error.
https://www.dropbox.com/s/4zljj6kv4slyh5i/screen .PNG?dl=0

I hope to find the problem, because the software is really perfect for me! Thank you very much!


13/02-15 00:19
#5 : 13/02-15 07:24
Fajar Rosyadi
Fajar Rosyadi
Posts: 3
Reply to #3:

Deleting apps setting is not help. The problem will gone if i move or rename the folder of executable file located, but it only for once, the second time i run the program, the error will come again. My temporary solution is directly run the program from winRAR or 7z, so it will be run from temp folder.


13/02-15 07:24 - edited 13/02-15 07:26
#6 : 17/02-15 21:40
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #5:
I really don't understand this problem. I am not able to reproduce it at all. Are you running the latest version? Have you downloaded it from this website? What triggers the problem? If you open the program from a new location, close it without clicking any buttons in the program, and open it again, does the problem happen again? Are you running any kind of antivirus programs?


17/02-15 21:40
#7 : 19/02-15 14:54
Fajar Rosyadi
Fajar Rosyadi
Posts: 3
Reply to #6:

Yes, i download the latest version from this website, and i use Avira for my laptop.
I notice the problem after re-install the OS and install update.
If I open the program from a new location, close it without clicking any buttons, it only work for once, second time i run the program, the problem is come again.
Is it possible that the problem is caused by the new installed OS?

thanks


19/02-15 14:54
#8 : 19/02-15 18:21
Brian Seydlitz
Brian Seydlitz
Posts: 1
Reply to #7:

Yes. My software just started with the same error yesterday, although it had been a while since I have used it. This is by far the best renamer I've found and would like to keep using it. I'm also running W8.1 x64. I had used it successfully for about 6 months.

Your help is appreciated!

Bseyd



19/02-15 18:21
#9 : 20/02-15 08:05
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #7:
It is very odd behavior. I am currently running Windows 7, since I am not a fan of Windows8. I have not been able to reproduce the problem on Windows 7, but I will try to get a machine running Windows 8.1 x64 and try to reproduce the problem.
Is it possible to run software in some sort of compatibility mode in Windows 8.1?


20/02-15 08:05
#10 : 22/02-15 12:48
Desmond Chu
Desmond Chu
Posts: 5
Reply to #9:

Hi, I experienced the same problem with a new computer running windows 8.1 pro running AdvancedRenamer v3.65. Same error as the others:

"Exception EReadError in module ARen.exe at 00057F74. Error reading treeAddFolderTree.lndent: Access violation at address 00408B3B in module 'ARen.exe'. Read of address 00000008"

Tried running compadibility mode for windows 7 & XP SP3, plus 'Run as Administrator" results in the same error.


It is working on another computer which running v3.64 for the last 5 months with no problems and continues to work. I suspected it may have been a windows update as not all updates are installed on the new computer. I uninstalled the following updates:

- KB2934520
Optionals
- KB3000850
- KB3013769
- KB3013816

Uninstalled & reinstalled AdvancedRenamer v3.65 and appear to have fixed the error.
Not sure which update is the cause. I suspect it is KB2934520 Microsoft.NET Framework 4.5.2 update.

Hope that helps to diagnose the problem.


22/02-15 12:48 - edited 22/02-15 12:51
#11 : 22/02-15 14:32
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #10:
If this bug eventually affects all Windows 8.1 users, I will consider it pretty serious and something that needs to be fixed. I am right now installing all updates onto a computer running Windows 8.1 to try to reproduce the problem. FYI. it takes for ever to install all those updates! After spending 45 minutes installing 24 updates, it is now installing some more updates. Windows Updates says it is "Installing 12 of 5 updates...", and NO it is not a typo! I am not a fan of Windows today.


22/02-15 14:32 - edited 22/02-15 14:34
#12 : 22/02-15 16:04
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #10:
I have installed all recommended and optional updates for this Windows 8.1 x64 based PC and have not been able to reproduce the problem. I even installed KB2934520 which did not give me any problems. The error message you get indicates that the aren.exe gets changed somehow, but I don't know how. I would like to establish some common scenario in which the program get corrupted, but I don't know why it happens. I cannot do anything about it without being able to reproduce the problem.


22/02-15 16:04
#13 : 22/02-15 23:47
Desmond Chu
Desmond Chu
Posts: 5
Reply to #12:

I take it back. I thought it worked last night when uninstalled the updates but the same error is coming up this morning.
The updates haven't been re-installed.

I also installed the updates on the older computer and AdvancedRenamer still works.


*Edit

Correction to the above.
AdvancedRenamer is not working for a power user account (same error message) but it continues to work on the administrator user account which I originally ran the uninstall of the windows updates and reinstalled AdvancedRenamer from.


22/02-15 23:47 - edited 23/02-15 07:31
#14 : 02/03-15 21:58
Opjit Ghuman
Opjit Ghuman
Posts: 2
Reply to #13:
I have the same problem that started without my understanding of the system changes. I use 8.1 on a thinkpad. I re-installed the program and ran in compatibility mode. It is working for now.

I am logged in as administrator.


02/03-15 21:58
#15 : 04/03-15 23:57
Desmond Chu
Desmond Chu
Posts: 5
Reply to #14:

Thanks for the tip Opjit Ghuman.
I've tried it on my computer and it appears to work as well. Compadibility: Windows 7
I was pretty sure compatibility mode wasn't working when I tired it previously but I guess I'm mistaken. Sorry if my info was misleading.


04/03-15 23:57 - edited 04/03-15 23:58
#16 : 05/03-15 08:34
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #15:
I am still very curious to why some users experience this problem. I will keep trying to make it fail, but have not had any luck yet.


05/03-15 08:34
#17 : 06/03-15 13:54
Andrew
Andrew
Posts: 1
Reply to #15:

I'm also getting this bug on windows 8.1 x64.

I've had 8.1 installed for a long time and advanced renamer was working fine a few months ago. I then tried to use Advanced Renamer about a week ago and it gave this error. I then tried compatibility mode for Windows 7 and that fixed the error for that day.

Now I've just tried opening it up again and the error appears even with compatibility mode enabled. I've tried re extracting (portable) and different compatibility modes but now it won't open at all. Very weird that compatibility mode fixed it for that one session last week and now it's not working any more.


06/03-15 13:54
#18 : 15/03-15 10:36
Jean Youssef
Jean Youssef
Posts: 2
i had the same problem before (few months back), but i don't know somehow i fixed it. but now i have it always and i cannot execute my software, i tried re installing the software, i tried uninstalling windows updates, also i tried the portable version but there was no success.

by the way, i am using windows 8.1 x64


15/03-15 10:36
#19 : 17/03-15 08:44
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #18:
When you guys say you are running Windows 8.1 x64, is that the home or the professional edition? Also are you using the native English language or a translation?


17/03-15 08:44
#20 : 18/03-15 07:50
Jean Youssef
Jean Youssef
Posts: 2
Reply to #19:
it is Windows 8.1 Single Language,
before the software was working great, suddenly it is giving this error.
usually i noticed it comes when u try to rename folders and then u delete them, so when the program starts it will not find the designated folders, so i used to changed few things and the program works again, but now it is not working, always i have the same error, whatever i do.

thank you for your support, i hope we can find a final solution soon.

Jean


18/03-15 07:50
#21 : 18/03-15 18:33
Opjit Ghuman
Opjit Ghuman
Posts: 2
Reply to #14:

Update: Ran fine for a few days and now the same error and had to uninstall. Using Windows 8.1 Pro x64.

Error log:

Faulting application name: ARen.exe, version: 3.65.0.0, time stamp: 0x547b2ae8
Faulting module name: KERNELBASE.dll, version: 6.3.9600.17278, time stamp: 0x53eeb460
Exception code: 0x0eedfade

Clearly something about permissions or ability to read or write a file that has occurred as a result of some windows update or a virus update. I use Avast Free.

It's a nice program so will check to see when it is operational. By the way, I also used Magic File Renamer (latest version) and that will not even launch with error in the same kernelbase.dll. No action on that for some time now.


18/03-15 18:33
#22 : 19/03-15 12:52
James
James
Posts: 1

I'm getting the same error. It may have to do with the Version of .net installed.

Running Windows 8.1




19/03-15 12:52
#23 : 23/03-15 22:24
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Just downloaded a Windows 8.1 image from https://www.modern.ie/en-us/virtualization-tools #downloads and tried to run Advanced Renamer with no problems. I will try to also install all updates, but that will take some time.


23/03-15 22:24
#24 : 23/03-15 22:42
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Installing updates were faster than expected. Installed all available updates for Windows 8.1 and still no problems. Have tried two different Windows 8.1 installations both with no problems. I have no idea what configuration on your computers that are making this problem.


23/03-15 22:42
#25 : 24/03-15 13:37
Desmond Chu
Desmond Chu
Posts: 5
Reply to #24:
Thank you for persisting to resolve this issue.

Like others, i'm experiencing the same thing. The error comes and goes when run in capability mode (Windows 7).
Can't see a pattern as to when it will work and when it doesn't.

I've tried on other windows 8.1 pro x64 machines with the same hardware and OS. The ones that work directly after installing never seem to have had a problem. Others just seem to pop up that error when it wants to irregardless what you do.

Not sure what we're missing.


24/03-15 13:37
#26 : 25/03-15 18:26
Robin
Robin
Posts: 1
Same error here (Windows 8.1 Professional [german])
Only thing changed since the last start without errors was the installation of kodi (with Microsoft Visual C++?)


25/03-15 18:26
#27 : 30/04-15 10:59
A
A
Posts: 4
Is there something new about that?
Thank you in advance


30/04-15 10:59
#28 : 04/05-15 14:04
Hugo Santos
Hugo Santos
Posts: 1
I have the same error.
I think It all start after install a software whit Microsoft Visual C++ pack.
Worked fine until…then.

Thank you for your support.


04/05-15 14:04
#29 : 09/05-15 10:18
Alex
Alex
Posts: 2
Hi everybody !

I'm encoutering the same error, and as it's was said, AdvancedRenamer is the must have renamer software, and so, I've try a lot of things to solve the problem and get AdvancedReanmer working again !!

After 2 format, and a step by step installation, each windows update, each software, I've found the responsible in my case ... Not any of my windows update still responsible, juste AutoDesk application ... Each autodesk application add a link in Explorer and this link get Windows 8 crashing and crashing on the desktop, way of almost invisible, but on Windows log I can see problem with :
QtCore_Ad_SyncNs_4.dll and KERNELBASE.dll
When I've install each update and each software, I've reboot and launch AdvancedRenamer, and it stop working after AutoDesk installation, after AutoDesk uninstall AdvancedReanmer start again normally ...

Hope it can help somebody of you, if you don't have any of AutoDesk software, look at software who is modifying Explorer tree, as link or shortcut in the tree.

Best regards, and thanks again for your so good and unbeliviable software, AdvancedRenamer, changed my life ! :)

P-S : Sorry for my bad English ...


09/05-15 10:18
#30 : 10/05-15 22:02
eurokim
eurokim
Posts: 1
Reply to #29:

I think the same as you

IT WORKED WELL before I installed autodesk 3ds max, autocad, revit and some 3d app etc

on my win8.1 pro x64





10/05-15 22:02 - edited 10/05-15 22:04
#31 : 12/05-15 19:02
A
A
Posts: 4
Reply to #30:
It's incredible!
I uninstalled Autodesk 360 and now AdvancedRenamer works again!

Thank you very much!!!


12/05-15 19:02
#32 : 15/05-15 18:53
Alex
Alex
Posts: 2
Reply to #31:
You're Welcome !

I'm happy it can help some of you !


15/05-15 18:53
#33 : 19/05-15 01:41
Desmond Chu
Desmond Chu
Posts: 5
Reply to #32:
Thank you so much!

Uninstalling Autodesk 360 also made advanced renamer work again for me!


19/05-15 01:41
#34 : 06/10-15 15:52
Henk Uitewaal
Henk Uitewaal
Posts: 3
Reply to #33:

Indeed Autodesk 360 was the cause with me as well (win 8.1 64b)! AR worked together with AD 360 before, so some update of AD 360 must be responsable for this.


06/10-15 15:52
#35 : 20/04-16 09:35
clintwelbar
clintwelbar
Posts: 1
More about.....Difference between Error and Exception

http://net-informations.com/faq/general/error.h tm

Clint


20/04-16 09:35