Cannot open file "arenexiftoolout.tmp"

Advanced Renamer forum
#1 : 10/02-16 08:15
John Grantman
John Grantman
Posts: 4
I can no longer use AdvancedRenamer and I am unable to troubleshoot the issue. The program launches but any use of ExifTool causes an error dialog box with message Cannot open file "arenexiftoolout.tmp".

I have tried the following steps:

Reset permissions on %TMP% location where "arenexiftoolout.tmp" is supposed to be located
Change program to run as Administrator and tried compatability with Win8, Win7... etc.
Move Temp folder (reassign %TMP% to new location)
Uninstall/Reinstall
Delete all references to AdvancedRenamer and ExifTool and Uninstall/Reinstall
Uninstall - Upgrade/Reinstall Windows 10 then reinstall AdvancedRenamer

Nothing works. I am beginning to think a Windows update may have created this issue. Its the only thing consistent after all the uninstall reinstall.

AdvancedRenamer and ExifTool were working without issue for months until approximately 4 days ago. Since then I can not avoid the error message.

The exact error message is as follows:

Cannot open file "C:\WINDOWS\TEMP\arenexiftoolout.tmp". The system cannot find the file specified.


C:\WINDOWS\TEMP is listed as TMP and TEMP in the environment variables within the Windows 10 installation.



Any help is appreciated.


John Grantman | jgrantman@gmail.com


10/02-16 08:15
#2 : 12/02-16 22:08
Kim Jensen
Kim Jensen
Administrator
Posts: 756
Reply to #1:
The file arenexiftoolout.tmp is used when Advanced Renamer communicates with ExifTool. The file is placed in the local temporary folder. It should be local to your current user. I find it odd that your temporary folder is c:\windows\temp since this is not your local user temporary folder. It should be something like c:\users\your username\appdata\local\temp. When Advanced Renamer needs a temporary folder, it asks Windows for one.

I will not recommend you to run Advanced Renamer as administrator. It should be able to run as your current user.

Please try to open a command console (Win+R and type cmd + Enter), and try these two commands:
echo %temp%
echo %tmp%
I would like to know the results of these two commands. They will probably be different if you run the command console as administrator. Make sure these paths exist and that you have write and read permissions for these folders.


12/02-16 22:08