Method-Timestamp-Filename pattern fails in batch

Advanced Renamer forum
#1 : 10/08-17 01:04
Posts: 1
Hi, I am trying to set file timestamps (create, modify) of a video file using exif. The program does not seem to want to do this using Method-Timestamp-Image date and time which works for image files.

But as Method-Add-ExifTool:CreateDate> works I am trying now to:
1) rename file with timestamp included the new name,
2) read this timestamp from that name to set file timestamps and then
3) rename the file to its old name.

What I see is that step #1 and #3 work and #2 does not in a *batch*. If I perform these steps manually one by one #2 works fine. Also if I perform #1 and #3 in a batch that work well (but does not change file timestamps of course).

So there seems to be a bug in the program. The bug is that the Method-Timestamp-Image date and time in #2 step can not find the pattern at all. I tried the start of file name, the end of file name - no difference. I tried to reduce the pattern and it works if it reduced to "<year>" (but it probably reads "1362" instead). Anything more than that if fails.

Here are the details:
- original file name is MOV_1362.mp4
- step #1 renames it to MOV_1362^2017_07_29 04_22_05.mp4 (it adds ^<ExifTool:CreateDate> at index 9)
- step #2 pattern is <Year>_<Month>_<Day> <Hour>_<Min>_<Sec>

That step #2 fails in testing of batch - screen turns file name red.

Hope this can be fixed, please as it would make the program much more useful.

Cheers, Peter

10/08-17 01:04 - edited 10/08-17 01:09