Access violation at module js32.dll...

Advanced Renamer forum
#1 : 03/12-17 23:59
Leo Hart
Leo Hart
Posts: 1
I see there are others that have posted about this problem. I'm writing to say I'm seeing it as well and wanted to provide my system info.

I'm running Windows 10 and Advanced Renamer 3.80. When I try to run a rename batch script across more than 10 files I get the error message mentioned in the subject. I've tried all compatibility modes. I do hope we're able to find a resolution to this as the tool becomes a bit useless when you're trying to rename hundreds of files. I love the capabilities of this tool and would rather not seek out other solutions, but the recent upgrades all seem to suffer from the same bug, but with different error messages.


03/12-17 23:59
#2 : 05/01-18 21:04
Posts: 1
Reply to #1:

In my case the same error occures when trying to add video files to the list but only if video metadata is being analyzed. I upgraded exiftool to version (inside the folder of AR) but that didn't help. As the metadata is required for my script to work I added the files one after another to see when the error happens:

- for smaller files (i.e. sub ~5GB) one seemingly can add around 100GB at once to AR
- for larger files (i.e. >5GB but <10GB) it may fail even with 10 files
- if files are added in groups of five at some point AR always breaks

Would be great if you could fix this bug (32Bit Limit? too aggressive timeout for file import / metadata extraction?), renaming by hand or small batches isn't really an option and I just got my script working.

05/01-18 21:04 - edited 05/01-18 21:05