Cannot modify Created Date using Timestamp method

Advanced Renamer forum
#1 : 04/02-19 10:24
L B
L B
Posts: 50
I am trying to modify the Created Date of a bunch of folders to be equal to a Year-Month-Day pattern in the respective folders' name. The Timestamp method has the following attributes:

Apply To : Created Date and Time
FileName Pattern : <Year>-<Month>-<Day>

When I load the folders, there are NO errors shown in the "Error" column. The "New Created Date" column in ARen shows the expected new created date.

But when I execute the batch, I get a "Errors has been found" popup window with the list of items with error, which is all the items. The Error shown is "(101) Unknown Error" for all the items. I have no idea what this error is or means, and googling did not help.

I am getting this consistently. I even restarted Windows Explorer a couple of times thinking maybe it locked something, but no change. I still get this behavior.

Please help.


04/02-19 10:24
#2 : 04/02-19 16:35
David Lee
David Lee
Posts: 245
Reply to #1:
Would that be ErrorCode: 101, Error Desc: 101: "Unknown error: The system cannot find the path specified"?

If so then it looks like you may be exceeding the maximum path length allowed by the Windows API (MAXPATH) - which is usually 260 characters (in practice 259 characters plus a terminating NULL).

The path is the complete string, including the volume, folder structure, filename and extension - eg C:\Folder\Subfolder1\Subfolder2\...\SubfolderN\Filename.extension<NULL>

ARen will only check the size of the filename itself (and indicate the error "Filename too long" if it is greater than the file system limit of 255 characters). The path length restriction is specific to the Windows API and so is not checked until ARen tries to rename the file, which is why you get an unknown system error.

If this is your problem then your options are either to shorten the filename or else move the folder closer to root (ie reduce the depth of sub-folders) in order to reduce the total length of the path.

Please let us know if this explains your error.

It may be helpful to add that in a script "item.filename" will return the path
and "item.filename.length" will return the path length (not including the terminating NULL) for each file in the list

Note that the behaviour is somewhat counter-intuitive: item.filename returns the PATHNAME whereas item.name returns the FILENAME.


04/02-19 16:35
#3 : 04/02-19 17:20
L B
L B
Posts: 50
Reply to #2:

The error just says 101 Unknown Error. No other info is given.

https://imgur.com/UDfKc79

I tried the script for the path length and all the folders in question are of length well below 200. So, it does not seem like that's the issue.

I do have a parent folder in the path that has square brackets in it (C:\[Vacations]\...), but so far, ARen has not taken issue to this while renaming folder names. But just to check, I moved some of the folders to a path that did not have special characters, but I still get the error.

Another thing I accidentally ended up observing is that ARen throws an access violation error if I choose the option "Stop Batch" in the error window and start the batch again.

https://imgur.com/SfH5gTn


04/02-19 17:20
#4 : 04/02-19 18:04
David Lee
David Lee
Posts: 245
Reply to #3:
Apologies - your original query was completely explicit but for some reason I completely overlooked the function of the Timestamp method! My excuse is that I have never attempted to change attribute data using Advanced Renamer.

My comments were correct but apply to methods that modify the filenames rather than the date attributes.

Sorry about that!

Can you post examples of filenames that are giving you these errors?


04/02-19 18:04
#5 : 09/02-19 22:37
L B
L B
Posts: 50
Reply to #4:

Here are a few folder names:

Indonesia - 2015-09-08 - Bali - Water Park - x45 5mpx
Indonesia - 2015-09-10 - Bali - Restaurant - x25 5mpx
Indonesia - 2015-09-11 - Bali - Shopping Mall - x33 5mpx

I am using the date pattern from the folders to modify the Created Date of the folders using the Timestamp method as described earlier.


09/02-19 22:37
#6 : 09/02-19 23:41
David Lee
David Lee
Posts: 245
Reply to #5:
I've created the three folders as you described and the Timestamp method re-writes the Created date without error. The created time remains unchanged. It also works if the folders are flagged as read-only.

I only tried this on my Windows XP machine though.


09/02-19 23:41
#7 : 10/02-19 17:06
L B
L B
Posts: 50
Reply to #6:

I am using Win10. And I suspect something is locking something somewhere that is causing these errors. I just can't figure out what. I wish ARen was more articulate about the error.


10/02-19 17:06